Epeny

14 Avril 2021 à 16:57

73

Non résolu

Problème avec grunt.js

Bonjour à tous,


Je suis en train de suivre ce tuto sur Github pour découvrir et lancer l'application.


Dans ce tuto on m'indique d'abord installer ( Node.js, Python, Grunt) ce qui est déjà fait, mais j'ai un autre problème qui empêche de lancer l'application à travers la ligne de commande.


Pour lancer l'application j'ai lancé cette ligne de commande :


grunt runPythonTests


mais j'obtiens des messages erreurs :


Loading "jinja.coffee" tasks...ERROR
>> Error: Grunt attempted to load a .coffee file but CoffeeScript was not installed.
>> Please run `npm install --dev coffeescript` to enable loading CoffeeScript.

Running "shell:pipInstall" (shell) task
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support pip 21.0 will remove support for this functionality.
Requirement already satisfied: requests in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 1)) (2.25.1)
Requirement already satisfied: webtest in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 2)) (2.0.35)
Requirement already satisfied: chardet<5,>=3.0.2 in /usr/lib/python2.7/dist-packages (from requests->-r requirements.txt (line 1)) (3.0.4)
Requirement already satisfied: urllib3<1.27,>=1.21.1 in /usr/local/lib/python2.7/dist-packages (from requests->-r requirements.txt (line 1)) (1.26.3)
Requirement already satisfied: idna<3,>=2.5 in /usr/local/lib/python2.7/dist-packages (from requests->-r requirements.txt (line 1)) (2.10)
Requirement already satisfied: certifi>=2017.4.17 in /usr/local/lib/python2.7/dist-packages (from requests->-r requirements.txt (line 1)) (2020.12.5)
Requirement already satisfied: WebOb>=1.2 in /usr/local/lib/python2.7/dist-packages (from webtest->-r requirements.txt (line 2)) (1.8.7)
Requirement already satisfied: six in /usr/local/lib/python2.7/dist-packages (from webtest->-r requirements.txt (line 2)) (1.14.0)
Requirement already satisfied: waitress>=0.8.5 in /usr/local/lib/python2.7/dist-packages (from webtest->-r requirements.txt (line 2)) (1.4.4)
Requirement already satisfied: beautifulsoup4 in /usr/local/lib/python2.7/dist-packages (from webtest->-r requirements.txt (line 2)) (4.9.3)
Requirement already satisfied: soupsieve<2.0,>1.2; python_version < "3.0" in /usr/local/lib/python2.7/dist-packages (from beautifulsoup4->webtest->-r requirements.txt (line 2)) (1.9.6)
Requirement already satisfied: backports.functools-lru-cache; python_version < "3" in /usr/local/lib/python2.7/dist-packages (from soupsieve<2.0,>1.2; python_version < "3.0"->beautifulsoup4->webtest->-r requirements.txt (line 2)) (1.6.1)


Ensuite j'ai décidé d'installer CoffeeScript avec cette ligne de commande :


npm install --include=dev coffeescript


j'obtiens encore des messages erreurs :


npm ERR! code EBADPLATFORM
npm ERR! notsup Unsupported platform for fsevents@2.1.3: wanted {"os":"darwin"} (current: {"os":"linux","arch":"x64"})
npm ERR! notsup Valid OS:    darwin
npm ERR! notsup Valid Arch:  undefined
npm ERR! notsup Actual OS:   linux
npm ERR! notsup Actual Arch: x64

npm ERR! A complete log of this run can be found in:
npm ERR!     /root/.npm/_logs/2021-03-11T15_42_35_280Z-debug.log


Je voudrais savoir qu'est-ce que signifie les messages d'erreurs que j'ai obtenu ? Quelle ligne de commande peut corriger cette erreur ?


Car j'ai bien compris cette application peut-être ne supporte pas aux paramètre de mon PC.


Merci d'avance pour vos réponses

Cette pub permet au site de vivre ...

4 commentaires

Bonsoir @Epeny :


Nous n'avons reçu aucune réponse de ta part...

Si tu es amené à créer d'autres topics, assures-toi d'être actif et de répondre aux utilisateurs qui ont pris le temps de t'aider 😉

Je ferme ce topic.

Bonsoir @Epeny 😀,


ça marche, redis-nous si tu as corrigé le problème 😁

Bonjour @Flomir,


Je vais aller suivre cet article, je te ferais signe lorsque je vais terminer à corriger le problème.

Salut @Epeny 😄!


Regarde cette onglet et fais les commandes dans l'ordre: voir_ici 😄


Redis-nous 😏

Cette pub permet au site de vivre ...