Chaandgus

20 Septembre 2021 à 19:12 (Édité)

162

Non résolu

Barre de recherche

Hello,


J'ai suivi cette vidéo pour la barre de recherche : https://www.youtube.com/watch?v=_EKDdNemV0k


Je suis sous Firefox, dans ma console lorsque je tape "o" pour le echo 'ok' cf (à 10 min) de recherche_utilisateur.php, j'obtiens deux messages d'erreurs :


GET https://nomdedomaineperso.com/favicon.ico

[HTTP/2 404 Not Found 0ms]


Chargement du contenu mixte actif « http://nomdedomaineperso.com/fonctions/recherche_utilisateur?user=o » (non sécurisé) sur une page sécurisée

ns1.chaandgus.com


Blocage d’une requête multiorigine (Cross-Origin Request) : la politique « Same Origin » ne permet pas de consulter la ressource distante située sur https://nomdedomaineperso.com/fonctions/recherche_utilisateur?user=o. Raison : l’en-tête « x-requested-with » n’est pas autorisé d’après l’en-tête « Access-Control-Allow-Headers » de la réponse de pré-vérification des requêtes CORS.


Blocage d’une requête multiorigine (Cross-Origin Request) : la politique « Same Origin » ne permet pas de consulter la ressource distante située sur https://nomdedomaineperso.com/fonctions/recherche_utilisateur?user=o. Raison : échec de la requête CORS.


Quelqu'un aurait-il la solution svp ? 😀

Est-ce lié à la version de jquery ?

Voici ce que j'ai dans les scripts en ligne :


<!-- premier lien de https://developers.google.com/speed/libraries -->

   <script src="https://ajax.googleapis.com/ajax/libs/jquery/3.6.0/jquery.min.js"></script>

   <!-- <script src="https://code.jquery.com/jquery-3.2.1.slim.min.js"></script>-->

   <script src="https://code.jquery.com/jquery-3.2.1.min.js"></script>

   <script src="https://cdnjs.cloudflare.com/ajax/libs/popper.js/1.12.9/umd/popper.min.js"></script>

   <script src="https://maxcdn.bootstrapcdn.com/bootstrap/4.0.0/js/bootstrap.min.js"></script>

   <script src="js/bootstrap.min.js"></script>


Il m'a aussi fallu désactiver la protection de Firefox.


Merci à vous

Cette pub permet au site de vivre ...

4 commentaires

Hello à tous !! 🖐️


Je suis enfin de retour. Meric pour vos retours.


@ael : oui le site existe et est en ligne

@Kam3leoN : j'ai tout plein d'autres pahges qui fonctionnent


Je n'ai plus le message initial du topic mais lorsque je saisi du texte ("h" dans cet exemple) dans la barre de recherche, la console affiche :

Blocage du chargement du contenu mixte actif (mixed active content) « http://nomdedomainepersonel/fonctions/recherche_utilisateur?user=h »

Auriez-vous une idée svp ? Tout fonctionne avec le nom de domaine sinon.


Merci

Bonjour @Chaandgus,


Nous n'avons reçu aucune réponse de ta part, je ferme ce topic ! Lorsque tu auras besoin d'aide, pense à répondre aux questions posées afin que les internautes ayant le même problème que toi puissent connaître la ou les solution(s) 😉


Néanmoins, bonne continuation à toi 😎

C'est juste un problème d'accès...

En gros tu as une erreur 404 car le navigateur ne peut pas accéder à la ressources demandés en autre favicon.ico et ta requête.


Si il est en ligne :

  • Soit ton URL est mauvaise, ce qui ne fait aucun doute au vu du nom de domaine.
  • Soit les fichiers sont absent du serveur.


Si il n'est pas en ligne, modifie https://nomdedomaineperso.com/ par http://localhost/ et je pense qu'il te manque un dossier genre /NomDeProjet/ à moins que tu ne mettes tous à la racine de www/.

Hello,


Il existe ton site nomdedomaineperso.com ?

j'ai l'impression que tu as oublié de modifier nomdedomaineperso par ton nom de domaine, ou ton adresse ip...

Cette pub permet au site de vivre ...